summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-05-06 07:37:28 +0200
committerThomas Haller <thaller@redhat.com>2018-05-11 16:51:20 +0200
commit3934a2c392e8d6c600b211afee871989a338a1fe (patch)
treeefc1be45d6a2a8bfe3f28985313e7e59c47d0bce /meson.build
parent11fedad5445d8688740563a0fb9fd1162ec9e118 (diff)
build: set LD_LIBRARY_PATH and GI_TYPELIB_PATH variables in run-nm-test.sh
With autotools, we use libtool so that the right libraries are automatically found. Still, we won't find the right GI typelib. Add a mechanism so that when make/meson invokes the run-nm-test.sh runner, it passes the build-root directory. Also, try to autodetect when invoked manually.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index dc1524aa0d..4564c5632a 100644
--- a/meson.build
+++ b/meson.build
@@ -741,15 +741,13 @@ endif
test_args = [
'--called-from-make',
+ meson.build_root(),
'',
enable_valgrind ? valgrind.path() : '',
enable_valgrind ? valgrind_suppressions_path : '',
'--launch-dbus=auto'
]
-# FIXME
-#AC_SUBST(NM_LOG_COMPILER, 'LOG_COMPILER = "$(top_srcdir)/tools/run-nm-test.sh" --called-from-make "$(LIBTOOL)" "$(with_valgrind)" "'"$with_valgrind_suppressions"'" --launch-dbus=auto')
-
py3 = import('python3')
python = py3.find_python()