summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2017-12-20 10:42:41 +0100
committerThomas Haller <thaller@redhat.com>2017-12-21 10:50:33 +0100
commit0474441e2258eeecb356e2aa3cde5c7328828646 (patch)
tree25c879d620c6290fb95b15299c4295529f0049f0 /meson.build
parent298d156e36a8ce1b4008167fcea986955651aab9 (diff)
settings: drop unmaintained ifnet settings plugin of Gentoo
Even Gentoo disables this plugin since before 0.9.8 release of NetworkManager. Time to say goodbye. If somebody happens to show up to maintain it, we may resurrect it later. If "$distro_plugins=ifnet" was set, configure.ac would use that to autodetect --with-hostname-persist=gentoo. Replace that autodetect part by checking for /etc/gentoo-release file.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 0 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 2efa1ad6b3..f76ea718dd 100644
--- a/meson.build
+++ b/meson.build
@@ -222,7 +222,6 @@ endif
enable_ifcfg_rh = get_option('ifcfg_rh') or (distro == 'redhat')
enable_ifupdown = get_option('ifupdown') or (distro == 'debian')
-enable_ifnet = get_option('ifnet') or (distro == 'gentoo')
enable_config_plugin_ibft = get_option('config_plugin_ibft')
config_h.set10('WITH_SETTINGS_PLUGIN_IBFT', enable_config_plugin_ibft)
@@ -239,10 +238,6 @@ if config_plugins_default == ''
config_plugins += ['ifupdown']
endif
- if enable_ifnet
- config_plugins += ['ifnet']
- endif
-
if enable_config_plugin_ibft
config_plugins += ['ibft']
endif
@@ -972,7 +967,6 @@ output += '\nConfiguration_plugins (main.plugins=' + config_plugins_default + ')
output += ' ibft: ' + enable_config_plugin_ibft.to_string() + '\n'
output += ' ifcfg-rh: ' + enable_ifcfg_rh.to_string() + '\n'
output += ' ifupdown: ' + enable_ifupdown.to_string() + '\n'
-output += ' ifnet: ' + enable_ifnet.to_string() + '\n'
output += '\nHandlers for /etc/resolv.conf:\n'
output += ' resolvconf: ' + enable_resolvconf.to_string()
if enable_resolvconf