summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAntonio Cardace <acardace@redhat.com>2019-12-17 16:42:05 +0100
committerAntonio Cardace <acardace@redhat.com>2019-12-24 10:13:51 +0100
commitdf1d214b2ea7dc65cc8c20658c66a97eb222569a (patch)
treefc84e46c3650374279ddb38c478ebabc1d274fb7 /configure.ac
parent1e45865e4ff625698d7e9c86f0666b9896dc8e6c (diff)
clients: polkit-agent: implement polkit agent without using libpolkit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 6 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 24b3f7c435..22cecb6efc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -655,18 +655,13 @@ AC_DEFINE_UNQUOTED(NM_CONFIG_DEFAULT_MAIN_AUTH_POLKIT, "$enable_polkit", [The de
AC_SUBST(NM_CONFIG_DEFAULT_MAIN_AUTH_POLKIT_TEXT, "$enable_polkit")
PKG_CHECK_MODULES(POLKIT, [polkit-agent-1 >= 0.97], [have_pk_agent=yes],[have_pk_agent=no])
-AC_ARG_ENABLE(polkit-agent,
- AS_HELP_STRING([--enable-polkit-agent], [enable polkit agent for clients]),
- [enable_polkit_agent=${enableval}], [enable_polkit_agent=${have_pk_agent}])
-if (test "${enable_polkit_agent}" = "yes"); then
- if test x"$have_pk_agent" = x"no"; then
- AC_MSG_ERROR(Polkit agent is required)
- fi
- AC_DEFINE(WITH_POLKIT_AGENT, 1, [Define if you have polkit agent])
-else
- AC_DEFINE(WITH_POLKIT_AGENT, 0, [Define if you have polkit agent])
+if test x"$have_pk_agent" = x"no"; then
+ AC_MSG_ERROR(Polkit agent is required)
fi
-AM_CONDITIONAL(WITH_POLKIT_AGENT, test "${enable_polkit_agent}" = "yes")
+POLKIT_PACKAGE_PREFIX=`$PKG_CONFIG --variable=prefix polkit-agent-1`
+AC_DEFINE_UNQUOTED([POLKIT_PACKAGE_PREFIX],
+ ["$POLKIT_PACKAGE_PREFIX"],
+ [polkit-agent package prefix])
AC_ARG_ENABLE(modify-system, AS_HELP_STRING([--enable-modify-system], [Allow users to modify system connections]))
if test "${enable_modify_system}" = "yes"; then
@@ -1323,7 +1318,6 @@ if test "${enable_modify_system}" = "yes"; then
else
echo " policykit: main.auth-polkit=${enable_polkit} (restrictive modify.system)"
fi
-echo " polkit agent: ${enable_polkit_agent}"
echo " selinux: $have_selinux"
echo " systemd-journald: $have_systemd_journal (default: logging.backend=${nm_config_logging_backend_default})"
echo " hostname persist: ${hostname_persist}"