summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSayed Shah <sayshah@redhat.com>2020-06-09 16:22:51 -0400
committerThomas Haller <thaller@redhat.com>2020-06-19 12:34:40 +0200
commit9f77d26ad0ffaa51d9b262ea4d9b28bbc58b6f68 (patch)
treedec76878a96ee2b7844c98f48d53939db327abdd /configure.ac
parent38d291f2294dd15d9cb128a693d20b34df7046f1 (diff)
build: create check for python black
If python black is install then it would check the formating of all of the python files and test the for it. Otherwise, it would just simply ignore the python black if python black is not installed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 175ee554ed..2ace7ecaee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1272,6 +1272,10 @@ else
have_introspection=no
fi
+# check for python black. And check if all files are formatted with python black
+AC_PATH_PROG(BLACK, black)
+AM_CONDITIONAL(WITH_PYTHON_BLACK, test "${BLACK}" != "")
+
# check for pregenerated manpages and documentation to be installed
use_pregen_docs=no
if test "$build_docs" != "yes" -a \