summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-12-15 14:28:45 +0100
committerThomas Haller <thaller@redhat.com>2019-12-16 10:22:09 +0100
commit9e02a676196300370487b39cbcff4e28d6c5f27c (patch)
treeaf6373d1ca2b7cd64994fc9c875964267ae5277a /configure.ac
parenta1771c738dd2e1437bd9f7c73805fd8a1b1b3d1d (diff)
parent0d155d1821875ab0de1ebe95570e5684daeb7d52 (diff)
systemd: merge branch systemd into master
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 44bf51a11f..4889c536a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,6 +91,33 @@ AC_CHECK_DECLS([
#include <sys/mman.h>
]])
+AC_CHECK_DECLS([
+ pidfd_open],
+ [], [], [[
+#include <stdlib.h>
+#include <unistd.h>
+#include <signal.h>
+#include <sys/wait.h>
+]])
+
+AC_CHECK_DECLS([
+ pidfd_send_signal],
+ [], [], [[
+#include <stdlib.h>
+#include <unistd.h>
+#include <signal.h>
+#include <sys/wait.h>
+]])
+
+AC_CHECK_DECLS([
+ rt_sigqueueinfo],
+ [], [], [[
+#include <stdlib.h>
+#include <unistd.h>
+#include <signal.h>
+#include <sys/wait.h>
+]])
+
AC_CHECK_HEADERS(sys/auxv.h)
AC_CHECK_DECLS([getrandom],