summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAntonio Cardace <acardace@redhat.com>2019-12-24 13:23:37 +0100
committerAntonio Cardace <acardace@redhat.com>2019-12-24 13:39:49 +0100
commit99a8a49c270803f3f1993ee8622fbbdad42b1b0a (patch)
treed738231e3729753295d8b7729a2816e180e62098 /configure.ac
parentcfbfe06da9ef223ffb94e8a2bc09e6d96c40e8bd (diff)
autotools: define the polkit-agent package prefix when building without polkit-devel
Fixes: df1d214b2 (clients: polkit-agent: implement polkit agent without using libpolkit)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 22cecb6efc..e54b88957a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -656,13 +656,15 @@ AC_SUBST(NM_CONFIG_DEFAULT_MAIN_AUTH_POLKIT_TEXT, "$enable_polkit")
PKG_CHECK_MODULES(POLKIT, [polkit-agent-1 >= 0.97], [have_pk_agent=yes],[have_pk_agent=no])
if test x"$have_pk_agent" = x"no"; then
- AC_MSG_ERROR(Polkit agent is required)
+ POLKIT_PACKAGE_PREFIX="/usr"
+else
+ POLKIT_PACKAGE_PREFIX=`$PKG_CONFIG --variable=prefix polkit-agent-1`
fi
-POLKIT_PACKAGE_PREFIX=`$PKG_CONFIG --variable=prefix polkit-agent-1`
AC_DEFINE_UNQUOTED([POLKIT_PACKAGE_PREFIX],
["$POLKIT_PACKAGE_PREFIX"],
[polkit-agent package prefix])
+
AC_ARG_ENABLE(modify-system, AS_HELP_STRING([--enable-modify-system], [Allow users to modify system connections]))
if test "${enable_modify_system}" = "yes"; then
NM_MODIFY_SYSTEM_POLICY="yes"