summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-11-12 15:54:22 +0100
committerThomas Haller <thaller@redhat.com>2019-11-28 19:52:18 +0100
commit69f048bf0ca387d2dc4683cfdfe9d170bfceb52b (patch)
tree9e484b28c71e3b9c34cec8ad9bb330d1cecd6e85 /configure.ac
parent2b6f5a305c6004843213fd23955d51628232643f (diff)
cloud-setup: add tool for automatic IP configuration in cloud
This is a tool for automatically configuring networking in a cloud environment. Currently it only supports IPv4 on EC2, but it's intended for extending to other cloud providers (Azure). See [1] and [2] for how to configure secondary IP addresses on EC2. This is what the tool currently aims to do (but in the future it might do more). [1] https://aws.amazon.com/premiumsupport/knowledge-center/ec2-ubuntu-secondary-network-interface/ It is inspired by SuSE's cloud-netconfig ([1], [2]) and ec2-net-utils package on Amazon Linux ([3], [4]). [1] https://www.suse.com/c/multi-nic-cloud-netconfig-ec2-azure/ [2] https://github.com/SUSE-Enceladus/cloud-netconfig [3] https://github.com/aws/ec2-net-utils [4] https://github.com/lorengordon/ec2-net-utils.git It is also intended to work without configuration. The main point is that you boot an image with NetworkManager and nm-cloud-setup enabled, and it just works.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4961e91ce7..7bd70ef7ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1014,6 +1014,17 @@ else
fi
AM_CONDITIONAL(BUILD_NMCLI, test "$build_nmcli" = yes)
+AC_ARG_WITH(nm-cloud-setup,
+ AS_HELP_STRING([--with-nm-cloud-setup=yes|no], [Build nm-cloud-setup]))
+if test "$with_nm_cloud_setup" != no; then
+ PKG_CHECK_MODULES(LIBCURL, [libcurl >= 7.24.0], [have_libcurl=yes], [have_libcurl=no])
+ if test "$have_libcurl" != "yes"; then
+ AC_MSG_ERROR(--with-nm-cloud-setup requires libcurl library.)
+ fi
+ with_nm_cloud_setup=yes
+fi
+AM_CONDITIONAL(BUILD_NM_CLOUD_SETUP, test "$with_nm_cloud_setup" == yes)
+
AC_ARG_WITH(nmtui,
AS_HELP_STRING([--with-nmtui=yes|no], [Build nmtui]))
if test "$with_nmtui" != no; then
@@ -1303,6 +1314,7 @@ echo " libteamdctl: $enable_teamdctl"
echo " ovs: $enable_ovs"
echo " nmcli: $build_nmcli"
echo " nmtui: $build_nmtui"
+echo " nm-cloud-setup: $with_nm_cloud_setup"
echo " iwd: $ac_with_iwd"
echo