summaryrefslogtreecommitdiff
path: root/clients/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-12-16 14:59:37 +0100
committerThomas Haller <thaller@redhat.com>2017-12-18 11:25:06 +0100
commit0735b35dd0fe87285f85c0040dfcb53cec2d1bd9 (patch)
tree91f9836bba6c365a24846869317bec15f427c0ac /clients/meson.build
parenta58cde8d2c9595941067be7c79e03ad34463d63a (diff)
build: use template files for enum types' sources generation
Source files for enum types are generated by passing segments of the source code of the files to the `glib-mkenums` command. This patch removes those parameters where source code is used from meson build files by moving those segmeents to template files. https://mail.gnome.org/archives/networkmanager-list/2017-December/msg00057.html
Diffstat (limited to 'clients/meson.build')
-rw-r--r--clients/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/clients/meson.build b/clients/meson.build
index 6c00fc0a28..4efbaea5a3 100644
--- a/clients/meson.build
+++ b/clients/meson.build
@@ -23,7 +23,7 @@ endif
executable(
name,
- [name + '.c', libnm_core_enums_h],
+ [name + '.c', libnm_core_enum[1]],
include_directories: incs,
dependencies: deps,
c_args: cflags,