summaryrefslogtreecommitdiff
path: root/callouts/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2011-05-02 22:38:51 -0500
committerDan Williams <dcbw@redhat.com>2011-05-02 22:54:28 -0500
commitf898dbf1a9cb657c3970fc9044d99dc46455f690 (patch)
tree7648cc3224e6cb77aa0e6bc1ccf746f8b688a8f6 /callouts/Makefile.am
parenta2fc80b0ea1e33224725f541098cd72d2f26b815 (diff)
dispatcher: enhance dispatcher script environment (bgo #648382)
For VPN connections, the interface name would be that of the VPN's IP interface, but the script environment would be the that of the VPN's parent device. Enhance the environment by adding any VPN specific details as additional environment variables prefixed by "VPN_". Leave the existing environment setup intact for backwards compatiblity. Additionally, the dispatcher never got updated for IPv6 support, so push IPv6 configuration and DHCPv6 configuration into the environment too. Even better, push everything the dispatcher needs to it instead of making the dispatcher make D-Bus requests back to NM, which sometimes fails if NM has already torn down the device or the connection which the device was using. And add some testcases to ensure that we don't break backwards compat, the testcases here were grabbed from a 0.8.4 machine with a hacked up dispatcher to dump everything it was given from NM.
Diffstat (limited to 'callouts/Makefile.am')
-rw-r--r--callouts/Makefile.am35
1 files changed, 33 insertions, 2 deletions
diff --git a/callouts/Makefile.am b/callouts/Makefile.am
index 9fcdd6c7c0..4a1ea7ca55 100644
--- a/callouts/Makefile.am
+++ b/callouts/Makefile.am
@@ -1,3 +1,13 @@
+SUBDIRS=. tests
+
+###########################################
+# Test libraries
+###########################################
+
+noinst_LTLIBRARIES = \
+ libtest-dispatcher-envp.la
+
+
dbusservicedir = $(DBUS_SYS_DIR)
dbusservice_DATA = \
nm-dhcp-client.conf \
@@ -41,7 +51,9 @@ nm_avahi_autoipd_action_LDADD = \
nm_dispatcher_action_SOURCES = \
nm-dispatcher-action.c \
- nm-dispatcher-action.h
+ nm-dispatcher-action.h \
+ nm-dispatcher-utils.c \
+ nm-dispatcher-utils.h
nm_dispatcher_action_CPPFLAGS = \
-I${top_srcdir} \
@@ -54,7 +66,6 @@ nm_dispatcher_action_CPPFLAGS = \
-DLIBEXECDIR=\"$(libexecdir)\"
nm_dispatcher_action_LDADD = \
- $(top_builddir)/libnm-glib/libnm-glib.la \
$(top_builddir)/libnm-util/libnm-util.la \
$(DBUS_LIBS) \
$(GLIB_LIBS)
@@ -62,6 +73,26 @@ nm_dispatcher_action_LDADD = \
nm-dispatcher-glue.h: nm-dispatcher.xml
$(AM_V_GEN) dbus-binding-tool --prefix=nm_dispatcher --mode=glib-server --output=$@ $<
+###########################################
+# dispatcher envp
+###########################################
+
+libtest_dispatcher_envp_la_SOURCES = \
+ nm-dispatcher-utils.c \
+ nm-dispatcher-utils.h
+
+libtest_dispatcher_envp_la_CPPFLAGS = \
+ -I${top_srcdir}/include \
+ -I${top_srcdir}/libnm-util \
+ $(GLIB_CFLAGS) \
+ $(DBUS_CFLAGS)
+
+libtest_dispatcher_envp_la_LIBADD = \
+ $(top_builddir)/libnm-util/libnm-util.la \
+ $(GLIB_LIBS) \
+ $(DBUS_LIBS)
+
+
udevrulesdir = $(UDEV_BASE_DIR)/rules.d
udevrules_DATA = 77-nm-olpc-mesh.rules