summaryrefslogtreecommitdiff
path: root/callouts/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2007-08-14 18:35:38 +0000
committerDan Williams <dcbw@redhat.com>2007-08-14 18:35:38 +0000
commit93f08e2f11ca8f5b55cfe0f10f8c2c520b42175f (patch)
tree635741a55c27abf25d53fae608c99bc859bb96d6 /callouts/Makefile.am
parent9bcbbb1cca62d0483baa5409a8b6d80602c96a49 (diff)
2007-08-14 Dan Williams <dcbw@redhat.com>
* callouts/Makefile.am src/dhcp-manager/nm-dhcp-manager.c src/dhcp-manager/nm-dhcp-manager.h src/dhcp-manager/Makefile.am - Change install location of nm-dhcp-client.action to ${prefix}/libexec git-svn-id: http://svn-archive.gnome.org/svn/NetworkManager/trunk@2682 4912f4e0-d625-0410-9fb7-b9a5a253dbdc
Diffstat (limited to 'callouts/Makefile.am')
-rw-r--r--callouts/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/callouts/Makefile.am b/callouts/Makefile.am
index fbb5652e8e..a26d5505c2 100644
--- a/callouts/Makefile.am
+++ b/callouts/Makefile.am
@@ -1,9 +1,7 @@
dbusservicedir = $(DBUS_SYS_DIR)
dbusservice_DATA = nm-dhcp-client.conf
-calloutdir = $(sysconfdir)/NetworkManager/callouts
-
-callout_PROGRAMS = nm-dhcp-client.action
+libexec_PROGRAMS = nm-dhcp-client.action
nm_dhcp_client_action_SOURCES = \
nm-dhcp-client-action.c
@@ -13,7 +11,8 @@ nm_dhcp_client_action_CPPFLAGS = \
$(GTHREAD_CFLAGS) \
-DDBUS_API_SUBJECT_TO_CHANGE \
-DG_DISABLE_DEPRECATED \
- -DSYSCONFDIR=\"$(sysconfdir)\"
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
+ -DLIBEXECDIR=\"$(libexecdir)\"
nm_dhcp_client_action_LDADD = \
$(DBUS_LIBS) \