summaryrefslogtreecommitdiff
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorJustin Kim <justin.kim@collabora.com>2017-07-31 14:38:34 +0900
committerOlivier CrĂȘte <olivier.crete@collabora.com>2017-11-07 14:34:48 -0500
commitf78be9d6988b1c3d1482a981c94a545e79645e43 (patch)
tree3ca93e95f59c9bfc8411eb290258d9d5971deb7d /ext/Makefile.am
parent07819afda461f5e4d77c9be9f484a7aae3c5ec8c (diff)
srt: Introduce SRT source and sink
SRT[0] is an open source transport technology[1] that optimizes streaming performance across unpredictable networks. Although SRT is based on UDP, it works like connection-oriented protocol. However, it doesn't mean that the SRT server or client is necessarily to link to a receiver or a sender so, here, the pairs of source and sink elements are introduced. - srtserversink: SRT server to feed SRT stream - srtclientsrc: SRT client to get SRT stream from srtserversink - srtclientsink: SRT client to send SRT stream - srtserversrc: SRT server to listen from srtclientsink [0] https://github.com/Haivision/srt [1] http://www.srtalliance.org/ https://bugzilla.gnome.org/show_bug.cgi?id=785730
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index aeaa9f1f6..0c35ff53e 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -328,6 +328,12 @@ else
SPC_DIR=
endif
+if USE_SRT
+SRT_DIR=srt
+else
+SRT_DIR=
+endif
+
if USE_SRTP
SRTP_DIR=srtp
else
@@ -457,6 +463,7 @@ SUBDIRS=\
$(SPANDSP_DIR) \
$(GME_DIR) \
$(SPC_DIR) \
+ $(SRT_DIR) \
$(SRTP_DIR) \
$(TELETEXTDEC_DIR) \
$(WILDMIDI_DIR) \
@@ -522,6 +529,7 @@ DIST_SUBDIRS = \
soundtouch \
spandsp \
spc \
+ srt \
srtp \
gme \
teletextdec \