summaryrefslogtreecommitdiff
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2016-06-06 15:10:05 -0400
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2016-06-21 13:46:00 -0400
commit398f7059fc8eb226f3aa67287ef466328cfd1e94 (patch)
tree7031283ad2201f2885218fcf2acb44ee2a5533d3 /ext/Makefile.am
parentcf6a517d41eb76e792bd76ae34bda08be401c499 (diff)
webrtcdsp: Add WebRTC Audio Processing support
This DSP library can be used to enhance voice signal for real time communication call. In implements multiple filters like noise reduction, high pass filter, echo cancellation, automatic gain control, etc. The webrtcdsp element can be used along, or with the help of the webrtcechoprobe if echo cancellation is enabled. The echo probe should be placed as close as possible to the audio sink, while the DSP is generally place close to the audio capture. For local testing, one can use an echo loop pipeline like the following: autoaudiosrc ! webrtcdsp ! webrtcechoprobe ! autoaudiosink This pipeline should produce a single echo rather then repeated echo. Those elements works if they are placed in the same top level pipeline. https://bugzilla.gnome.org/show_bug.cgi?id=767800
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index f97ef44c8..d0bf51553 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -412,6 +412,12 @@ else
VULKAN_DIR=
endif
+if USE_WEBRTCDSP
+WEBRTCDSP_DIR=webrtcdsp
+else
+WEBRTCDSP_DIR=
+endif
+
SUBDIRS=\
$(VOAACENC_DIR) \
$(ASSRENDER_DIR) \
@@ -481,7 +487,8 @@ SUBDIRS=\
$(WEBP_DIR) \
$(X265_DIR) \
$(DTLS_DIR) \
- $(VULKAN_DIR)
+ $(VULKAN_DIR) \
+ $(WEBRTCDSP_DIR)
DIST_SUBDIRS = \
assrender \
@@ -549,6 +556,7 @@ DIST_SUBDIRS = \
webp \
x265 \
dtls \
- vulkan
+ vulkan \
+ webrtcdsp
include $(top_srcdir)/common/parallel-subdirs.mak