summaryrefslogtreecommitdiff
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorMathieu Duponchelle <mathieu.duponchelle@opencreed.com>2016-11-16 13:18:53 -0300
committerThibault Saunier <thibault.saunier@osg.samsung.com>2016-11-17 13:25:33 -0300
commit087d9bc37606e98fc4413bfa2baa1d9e9efda9bf (patch)
tree3a8837a8261f2e9412044955a888768598b31545 /ext/Makefile.am
parenta7b0669ce8fe62e1584ff582fe000c2538e808cc (diff)
Adds a new Image Quality Assessment plugin.
It only offers one metric for now, "dssim", available if https://github.com/pornel/dssim was installed on the system at the time the plugin was compiled. The spearman correlation for dssim against the TID2008 dataset is 0.81, against 0.70 for the old ssim implementation, and it runs 15 times faster. https://bugzilla.gnome.org/show_bug.cgi?id=751324
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 16821e0be..6dfc6bc5a 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -142,6 +142,12 @@ else
GSM_DIR=
endif
+if USE_IQA
+IQA_DIR = iqa
+else
+IQA_DIR =
+endif
+
if USE_KATE
KATE_DIR=kate
else
@@ -457,6 +463,7 @@ SUBDIRS=\
$(FLUIDSYNTH_DIR) \
$(GSM_DIR) \
$(G729_DIR) \
+ $(IQA_DIR) \
$(KATE_DIR) \
$(LADSPA_DIR) \
$(LV2_DIR) \