summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2011-02-11 11:58:25 -0500
committerMatthias Clasen <mclasen@redhat.com>2011-02-11 11:58:25 -0500
commitbba71b1ecf2c6df4c6a39bfb471b363ef0b3e1ad (patch)
tree5e7407bb52691864b8a97bfd6fb280f782bb85b3
parentd1f3b5422a54893149fdf4fa85c3a21a27abb0fc (diff)
build
-rw-r--r--spice-gtk-build.patch19
-rw-r--r--spice-gtk.spec9
2 files changed, 27 insertions, 1 deletions
diff --git a/spice-gtk-build.patch b/spice-gtk-build.patch
new file mode 100644
index 0000000..3ad6621
--- /dev/null
+++ b/spice-gtk-build.patch
@@ -0,0 +1,19 @@
+diff -up spice-gtk-0.5/spice-gtk3-0.5/gtk/spice-session.c.glib-build spice-gtk-0.5/spice-gtk3-0.5/gtk/spice-session.c
+--- spice-gtk-0.5/spice-gtk3-0.5/gtk/spice-session.c.glib-build 2011-02-11 11:55:51.188263533 -0500
++++ spice-gtk-0.5/spice-gtk3-0.5/gtk/spice-session.c 2011-02-11 11:56:05.478084885 -0500
+@@ -984,7 +984,6 @@ int spice_session_get_connection_id(Spic
+ return s->connection_id;
+ }
+
+-#if !GLIB_CHECK_VERSION(2,28,0)
+ static guint64 g_get_monotonic_clock(void)
+ {
+ GTimeVal tv;
+@@ -994,7 +993,6 @@ static guint64 g_get_monotonic_clock(voi
+
+ return (((gint64) tv.tv_sec) * 1000000) + tv.tv_usec;
+ }
+-#endif
+
+ G_GNUC_INTERNAL
+ guint32 spice_session_get_mm_time(SpiceSession *session)
diff --git a/spice-gtk.spec b/spice-gtk.spec
index 4d02863..f7611b6 100644
--- a/spice-gtk.spec
+++ b/spice-gtk.spec
@@ -11,7 +11,7 @@
Name: spice-gtk
Version: 0.5
-Release: 4%{?dist}
+Release: 5%{?dist}
Summary: A GTK2 widget for SPICE clients
Group: System Environment/Libraries
@@ -37,6 +37,8 @@ BuildRequires: libtool
ExclusiveArch: %{ix86} x86_64
+Patch0: spice-gtk-build.patch
+
%description
Client libraries for SPICE desktop servers.
@@ -116,6 +118,8 @@ snappy is a tool to capture screen-shots of a SPICE desktop.
%prep
%setup -q -n spice-gtk-%{version} -c
+%patch0 -p1 -b .build
+
%if %{with_gtk3}
cp -a spice-gtk-%{version} spice-gtk3-%{version}
%endif
@@ -215,6 +219,9 @@ rm -rf %{buildroot}
%{_bindir}/spicy
%changelog
+* Fri Feb 11 2011 Matthias Clasen <mclasen@redhat.com> - 0.5-5
+- Fix build against glib 2.28
+
* Thu Feb 10 2011 Matthias Clasen <mclasen@redhat.com> - 0.5-4
- Rebuild against newer gtk