summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorAaron Plattner <aplattner@nvidia.com>2009-10-23 14:55:17 -0700
committerAaron Plattner <aplattner@nvidia.com>2009-10-23 15:12:14 -0700
commitcf794deacff4e9cec47d539a717d12c8865543ea (patch)
treee4ba1d0183b31a0ced28dbd812748b8366b3b0b0 /doc/Makefile.am
parentfceec0aa07e4acb471e80c0ecb7a1d5724025874 (diff)
Fix distcheck.
* Uninstall the docs if they were installed. * Remember to distribute Doxyfile and vdpau_data_flow.png in the tarball. Signed-off-by: Aaron Plattner <aplattner@nvidia.com> Reviewed-by: Stephen Warren <swarren@nvidia.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index e9ba15c..b5f96cd 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,6 +1,10 @@
all: html
install-data-local: install-html
+EXTRA_DIST = \
+ Doxyfile \
+ vdpau_data_flow.png
+
VDPAU_HEADER_DIR := $(top_srcdir)/include
VDPAU_HEADER_FILES := \
$(VDPAU_HEADER_DIR)/vdpau/vdpau.h \
@@ -14,8 +18,10 @@ html-out/%: Doxyfile $(VDPAU_HEADER_FILES)
if ENABLE_DOCS
html: html-out/index.html
install-html-local:
- $(install_sh) -d $(DESTDIR)$(docdir)/html
- $(install_sh) -m 644 html-out/* $(DESTDIR)$(docdir)/html
+ $(install_sh) -d "$(DESTDIR)$(docdir)/html"
+ $(install_sh) -m 644 html-out/* "$(DESTDIR)$(docdir)/html"
+uninstall-local:
+ $(RM) -r "$(DESTDIR)$(docdir)/html"
endif
clean-local: