summaryrefslogtreecommitdiff
path: root/include/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'include/meson.build')
-rw-r--r--include/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/meson.build b/include/meson.build
index dfca3c340..9682827dd 100644
--- a/include/meson.build
+++ b/include/meson.build
@@ -156,8 +156,10 @@ conf_data.set('_XITYPEDEF_POINTER', '1')
conf_data.set('LISTEN_TCP', get_option('listen_tcp'))
conf_data.set('LISTEN_UNIX', get_option('listen_unix'))
conf_data.set('LISTEN_LOCAL', get_option('listen_local'))
-# XXX: Configurable?
-conf_data.set('XTRANS_SEND_FDS', '1')
+
+if cc.has_header_symbol('sys/socket.h', 'SCM_RIGHTS')
+ conf_data.set('XTRANS_SEND_FDS', '1')
+endif
conf_data.set('TCPCONN', '1')
conf_data.set('UNIXCONN', '1')