summaryrefslogtreecommitdiff
path: root/hw/xquartz/bundle/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xquartz/bundle/Makefile.am')
-rw-r--r--hw/xquartz/bundle/Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/hw/xquartz/bundle/Makefile.am b/hw/xquartz/bundle/Makefile.am
index 801fdc7d8..b7776967f 100644
--- a/hw/xquartz/bundle/Makefile.am
+++ b/hw/xquartz/bundle/Makefile.am
@@ -1,20 +1,11 @@
-bin_SCRIPTS = x11app
-
-.PHONY: x11app
-
-x11app:
- xcodebuild CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" ARCHS="$(X11APP_ARCHS)"
-
install-data-hook:
- xcodebuild install DSTROOT="/$(DESTDIR)" INSTALL_PATH="$(APPLE_APPLICATIONS_DIR)" DEPLOYMENT_LOCATION=YES SKIP_INSTALL=NO ARCHS="$(X11APP_ARCHS)"
-
-clean-local:
- rm -rf build
+ ./mk_bundke.sh $(DESTDIR)$(APPLE_APPLICATIONS_DIR)/X11.app
resourcedir=$(libdir)/X11/xserver
resource_DATA = Xquartz.plist
EXTRA_DIST = \
+ mk_bundke.sh \
$(resource_DATA) \
Info.plist \
X11.icns \