summaryrefslogtreecommitdiff
path: root/hw/xfree86/os-support/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xfree86/os-support/meson.build')
-rw-r--r--hw/xfree86/os-support/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/hw/xfree86/os-support/meson.build b/hw/xfree86/os-support/meson.build
index b6e5c975d..0e021dbe1 100644
--- a/hw/xfree86/os-support/meson.build
+++ b/hw/xfree86/os-support/meson.build
@@ -45,6 +45,8 @@ if host_machine.system() == 'linux'
if build_acpi
srcs_xorg_os_support += 'linux/lnx_acpi.c'
endif
+ else
+ srcs_xorg_os_support += 'shared/pm_noop.c'
endif
elif host_machine.system() == 'solaris'
@@ -83,6 +85,7 @@ elif host_machine.system().endswith('bsd')
'bsd/bsd_VTsw.c',
'bsd/bsd_bell.c',
'bsd/bsd_init.c',
+ 'shared/pm_noop.c',
]
# XXX: APM