summaryrefslogtreecommitdiff
path: root/hw/kdrive/ephyr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/kdrive/ephyr/Makefile.am')
-rw-r--r--hw/kdrive/ephyr/Makefile.am47
1 files changed, 38 insertions, 9 deletions
diff --git a/hw/kdrive/ephyr/Makefile.am b/hw/kdrive/ephyr/Makefile.am
index cc3019fc7..604e22eaa 100644
--- a/hw/kdrive/ephyr/Makefile.am
+++ b/hw/kdrive/ephyr/Makefile.am
@@ -3,22 +3,47 @@ INCLUDES = \
@KDRIVE_CFLAGS@ \
-I$(srcdir)/../../../exa
-noinst_LIBRARIES = libxephyr.a libxephyr-hostx.a
+noinst_LIBRARIES = libxephyr-hostx.a libxephyr-hostxv.a libxephyr.a
bin_PROGRAMS = Xephyr
+
+libxephyr_hostx_a_SOURCES = \
+ hostx.c \
+ hostx.h
+
+libxephyr_hostx_a_INCLUDES = @XEPHYR_INCS@
+
+libxephyr_hostxv_a_SOURCES= \
+ ephyrhostvideo.c \
+ ephyrhostvideo.h
+
libxephyr_a_SOURCES = \
ephyr.c \
ephyr_draw.c \
+ ephyrvideo.c \
+ XF86dri.c \
+ ephyrdriext.c \
+ ephyrdri.c \
+ ephyrdri.h \
+ ephyrglxext.c \
+ ephyrglxext.h \
+ ephyrhostglx.c \
+ ephyrhostglx.h \
+ ephyrhostproxy.c \
+ ephyrhostproxy.h \
+ ephyrhostproxy.c \
+ ephyrproxyext.c \
+ ephyrproxyext.h \
os.c \
- hostx.h \
- ephyr.h
-
-libxephyr_hostx_a_SOURCES = \
- hostx.c \
- hostx.h
+ hostx.h \
+ ephyr.h \
+ ephyrlog.h
-libxephyr_hostx_a_INCLUDES = @XEPHYR_INCS@
+libxephyr_a_CFLAGS = \
+@LIBDRM_CFLAGS@ \
+-I$(top_srcdir) \
+@DRIPROTO_CFLAGS@
Xephyr_SOURCES = \
ephyrinit.c
@@ -26,13 +51,17 @@ Xephyr_SOURCES = \
Xephyr_LDADD = \
libxephyr.a \
libxephyr-hostx.a \
+ libxephyr-hostxv.a \
../../../exa/libexa.la \
@KDRIVE_LIBS@ \
- @XEPHYR_LIBS@
+ @XEPHYR_LIBS@ \
+ @LIBDRM_LIBS@ \
+ -lGL
Xephyr_DEPENDENCIES = \
libxephyr.a \
libxephyr-hostx.a \
+ libxephyr-hostxv.a \
@KDRIVE_LOCAL_LIBS@
relink: