summaryrefslogtreecommitdiff
path: root/hw/xfree86/loader/Makefile.am
diff options
context:
space:
mode:
authorAdam Jackson <ajax@benzedrine.nwnk.net>2006-06-21 20:49:21 -0400
committerAdam Jackson <ajax@benzedrine.nwnk.net>2006-06-21 20:49:21 -0400
commitd8135eb9e414bf6957f64c5102ee0ef7c2404c6f (patch)
tree2b1dafa1f5202fabf0e2caaa5e7ba9def10b7e3b /hw/xfree86/loader/Makefile.am
parent40aafaf154ba8a2cba857689d1481be2d4a610c2 (diff)
Unbreak unbreaking the loader. Re-add the symbol reference lists so that the
linker will include everything it's supposed to. This is a terrible solution, but ld semantics don't let you do anything better.
Diffstat (limited to 'hw/xfree86/loader/Makefile.am')
-rw-r--r--hw/xfree86/loader/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/hw/xfree86/loader/Makefile.am b/hw/xfree86/loader/Makefile.am
index 502bb5aeb..0cda5c159 100644
--- a/hw/xfree86/loader/Makefile.am
+++ b/hw/xfree86/loader/Makefile.am
@@ -1,6 +1,8 @@
noinst_LIBRARIES = libloader.a
-INCLUDES = $(XORG_INCS) -I$(srcdir)/../parser
+INCLUDES = $(XORG_INCS) -I$(srcdir)/../parser -I$(srcdir)/../dixmods/extmod \
+ -I$(srcdir)/../vbe -I$(top_srcdir)/miext/cw -I$(srcdir)/../int10 \
+ -I$(srcdir)/../ddc -I$(srcdir)/../i2c
#AM_LDFLAGS = -r
AM_CFLAGS = -DIN_LOADER $(XORG_CFLAGS) @SERVER_DEFINES@ @LOADER_DEFINES@
@@ -23,4 +25,9 @@ libloader_a_SOURCES = \
loadfont.c \
dlloader.c \
os.c \
+ dixsym.c \
+ extsym.c \
+ fontsym.c \
+ misym.c \
+ xf86sym.c \
$(SPARC_SOURCES)