summaryrefslogtreecommitdiff
path: root/hw/xfree86/common/Makefile.am
diff options
context:
space:
mode:
authorCyril Brulebois <kibi@debian.org>2010-11-11 18:36:45 +0100
committerCyril Brulebois <kibi@debian.org>2010-12-07 18:42:44 +0100
commit28b4c02d7463ffe5c29f803f5656c5ecfc040185 (patch)
treed03e02e063486b5b24b4f716ba6c891ca47260b1 /hw/xfree86/common/Makefile.am
parent838b9582280030a159878af566126cb0a523ec29 (diff)
Enable silent rules for cat and echo.
One gets this: | GEN lf3-xaaBitmap.c | GEN lf3-xaaBitmap.c | GEN lf3-xaaBitmap.c | GEN lf3-xaaBitmap.c | CC lf3-xaaBitmap.lo instead of this: | echo "#define LSBFIRST" > l3-xaaBitmap.c | echo "#define TRIPLE_BITS" >> l3-xaaBitmap.c | echo '#include "../../../../hw/xfree86/xaa/xaaBitmap.c"' >> l3-xaaBitmap.c | CC l3-xaaBitmap.lo Occurrences found using: | git grep -E '(cat|echo)' -- '*Makefile.am' Reviewed-by: Gaetan Nadon <memsize@videotron.ca> Signed-off-by: Cyril Brulebois <kibi@debian.org>
Diffstat (limited to 'hw/xfree86/common/Makefile.am')
-rw-r--r--hw/xfree86/common/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/hw/xfree86/common/Makefile.am b/hw/xfree86/common/Makefile.am
index 989208f4e..4abf2170d 100644
--- a/hw/xfree86/common/Makefile.am
+++ b/hw/xfree86/common/Makefile.am
@@ -24,8 +24,8 @@ BUSSOURCES = xf86pciBus.c xf86fbBus.c xf86noBus.c $(SBUS_SOURCES)
MODEDEFSOURCES = $(srcdir)/vesamodes $(srcdir)/extramodes
xf86DefModeSet.c: $(srcdir)/modeline2c.awk $(MODEDEFSOURCES)
- cat $(MODEDEFSOURCES) | LC_ALL=C $(AWK) -f $(srcdir)/modeline2c.awk > $@
- echo >> $@
+ $(AM_V_GEN)cat $(MODEDEFSOURCES) | LC_ALL=C $(AWK) -f $(srcdir)/modeline2c.awk > $@
+ $(AM_V_GEN)echo >> $@
BUILT_SOURCES = xf86DefModeSet.c