summaryrefslogtreecommitdiff
path: root/hw/kdrive/ephyr/Makefile.am
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2021-07-01 15:40:19 -0400
committerPovilas Kanapickas <povilas@radix.lt>2021-09-15 19:14:23 +0000
commit07fa12ad1d7018df92285b7f27dea0f128ef86c8 (patch)
tree2cbd9c92ab9663480884c8c33f42a5947bb31c11 /hw/kdrive/ephyr/Makefile.am
parent2906ee5e4a722138cccb3265a615da7705a52589 (diff)
ephyr/glamor: Port to EGL
There's no real benefit to using GLX, and the other DDXes are using EGL already, so let's converge on EGL so we can concentrate the fixes in one place. We go to some effort to avoid being the thing that requires libX11 here. We prefer EGL_EXT_platform_xcb over _x11, and if forced to use the latter we'll ask the dynamic linker for XGetXCBConnection and XOpenDisplay rather than link against xlib stuff ourselves. Xephyr is now a pure XCB application if it can be. Reviewed-by: Emma Anholt <emma@anholt.net>
Diffstat (limited to 'hw/kdrive/ephyr/Makefile.am')
-rw-r--r--hw/kdrive/ephyr/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/hw/kdrive/ephyr/Makefile.am b/hw/kdrive/ephyr/Makefile.am
index d12559b39..a3d6b1c02 100644
--- a/hw/kdrive/ephyr/Makefile.am
+++ b/hw/kdrive/ephyr/Makefile.am
@@ -41,8 +41,8 @@ GLAMOR_XV_SRCS = ephyr_glamor_xv.c
endif
GLAMOR_SRCS = \
- ephyr_glamor_glx.c \
- ephyr_glamor_glx.h \
+ ephyr_glamor.c \
+ ephyr_glamor.h \
$(GLAMOR_XV_SRCS) \
$()
endif