summaryrefslogtreecommitdiff
path: root/dix/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-11-30 19:53:29 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-11-30 19:53:29 -0800
commit8956f63a941bf0a5f157d47b33e6221601a75040 (patch)
tree4ec252656fed543013f7cfe31142ec1e6fe8bc82 /dix/Makefile.am
parentee9bdd3f4a14a42fb0747acc420966f0f669129b (diff)
Tell automake to STFU about the *.O files
automake will not stop whining about the *.O files not being in normal library name format, so just tell automake they are PROGRAMS so it builds them without bitching.
Diffstat (limited to 'dix/Makefile.am')
-rw-r--r--dix/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/dix/Makefile.am b/dix/Makefile.am
index d0d6e8785..a1f02c1b6 100644
--- a/dix/Makefile.am
+++ b/dix/Makefile.am
@@ -52,7 +52,7 @@ Xserver-dtrace.h: $(srcdir)/Xserver.d
dtrace-dix.o: $(top_srcdir)/dix/Xserver.d $(am_libdix_la_OBJECTS)
$(DTRACE) -G -C -o $@ -s $(top_srcdir)/dix/Xserver.d .libs/*.o
-noinst_LIBRARIES = dix.O
+noinst_PROGRAMS = dix.O
dix.O: dtrace-dix.o $(am_libdix_la_OBJECTS)
ld -r -o $@ .libs/*.o