summaryrefslogtreecommitdiff
path: root/Xext/Makefile.am
diff options
context:
space:
mode:
authorEamon Walsh <ewalsh@tycho.nsa.gov>2009-08-31 18:46:23 -0400
committerEamon Walsh <ewalsh@tycho.nsa.gov>2009-10-14 19:19:18 -0400
commitae8891ba0b63bfe6941a324e201d9ab7c645c0f3 (patch)
treec573b9f88fb3713463a7b55590a138d2d6004245 /Xext/Makefile.am
parent22b38f513c93c2f2aea5909878c3c9acae7d35c1 (diff)
xselinux: refactor extension code into smaller files.
New files: xselinux_ext.c: Extension init and request handlers. xselinux_hooks.c: XACE hook functions and other callbacks. xselinux_label.c: Object security-labeling code. xselinuxint.h: Shared internal functions. Signed-off-by: Eamon Walsh <ewalsh@tycho.nsa.gov>
Diffstat (limited to 'Xext/Makefile.am')
-rw-r--r--Xext/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Xext/Makefile.am b/Xext/Makefile.am
index ac45f955a..7287c4a62 100644
--- a/Xext/Makefile.am
+++ b/Xext/Makefile.am
@@ -80,7 +80,7 @@ endif
# SELinux extension: provides SELinux policy support for X objects
# requires X-ACE extension
-XSELINUX_SRCS = xselinux.c xselinux.h
+XSELINUX_SRCS = xselinux_ext.c xselinux_hooks.c xselinux_label.c xselinux.h xselinuxint.h
if XSELINUX
MODULE_SRCS += $(XSELINUX_SRCS)
endif
@@ -133,6 +133,7 @@ EXTRA_DIST = \
$(SCREENSAVER_SRCS) \
$(XACE_SRCS) \
$(XCSECURITY_SRCS) \
+ $(XSELINUX_SRCS) \
$(XCALIBRATE_SRCS) \
$(XINERAMA_SRCS) \
$(MULTIBUFFER_SRCS) \