summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2012-07-09 16:29:04 -0700
committerKeith Packard <keithp@keithp.com>2012-07-09 16:29:04 -0700
commitd1c639c006526b8cab14dac582508f3f54848967 (patch)
treebe1e03467013fb033eed62b9e17582f016e757dc /Makefile.am
parent329db3292223cccd4887062956622285c45a1523 (diff)
Add 'install-headers' target in the top-level Makefile
This target recursively locates directories with sdk headers and installs them all. Useful when you want to build a complete new X server and drivers without having to install the X server before the drivers are actually working. Signed-off-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cea140bea..9a628537d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -95,3 +95,10 @@ DIST_SUBDIRS = \
# gross hack
relink: all
$(AM_V_at)$(MAKE) -C hw relink
+
+install-headers: Makefile
+ +find . -name Makefile | while read m; do \
+ if grep -q install-sdkHEADERS $$m; then \
+ (cd `dirname "$$m"` && make install-sdkHEADERS) \
+ fi \
+ done