summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-29 18:45:48 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-29 18:45:48 -0200
commit5957fdd9ba2aba60e90a30bc3744f76ddb27b8d2 (patch)
tree3040f3b568090bd929f44566a6115e131f6d714d /Makefile.am
parentcb80b4493e116229d8cc46507dec0fed6febd949 (diff)
Janitor: Correct make distcheck and sparse warnings.
Use only one toplevel .gitignore file. It was tempting to also modify the code to not, first check if xrender is >= 0.8.2, and then, if failing, check for libXrender functions with different build options, but left as is, as it could be somehow useful at least as an example of being backwards compatible.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 880d3f6..39c15a9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,14 +28,12 @@ pkgconfig_DATA = xft.pc
CLEANFILES = xft-config
-EXTRA_DIST = xft-config.in xft.pc.in autogen.sh
-
-EXTRA_DIST += ChangeLog
+EXTRA_DIST = xft-config.in xft.pc.in ChangeLog
MAINTAINERCLEANFILES = ChangeLog
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog