summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2008-12-19 13:05:32 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2008-12-19 13:05:32 -0800
commitb5cc4a10c0fe365b40be19613777f192a1ada0db (patch)
tree0445016a002665745c3245471d3f6779eece62bc /configure.ac
parent377584bb71ccb2cc380c3a8f71f0acd7e755ad33 (diff)
Use XORG_CWARNFLAGS & XORG_CHANGELOG macros from xorg-macros 1.2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index eaa1821..f199743 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,10 @@ AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_CONFIG_HEADER(config.h)
AC_CONFIG_HEADERS([include/X11/fonts/fontconf.h])
+# Require xorg-macros version >= 1.2.0 for XORG_CWARNFLAGS & XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
+
# Check for progs
AC_PROG_CC
AC_PROG_LIBTOOL
@@ -208,12 +212,7 @@ PKG_CHECK_MODULES(XFONT, xproto xtrans fontsproto fontenc)
# Transport selection macro from xtrans.m4
XTRANS_CONNECTION_FLAGS
-if test "x$GCC" = "xyes"; then
- CWARNFLAGS="-Wall -Wpointer-arith -Wstrict-prototypes \
- -Wmissing-prototypes -Wmissing-declarations \
- -Wnested-externs -fno-strict-aliasing"
-fi
-AC_SUBST([CWARNFLAGS])
+XORG_CWARNFLAGS
case $host_os in
linux*)
@@ -229,6 +228,7 @@ esac
AC_SUBST([OS_CFLAGS])
XORG_RELEASE_VERSION
+XORG_CHANGELOG
AC_OUTPUT([Makefile
src/Makefile