summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 502996a0..4247894e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,6 +141,10 @@ case $host_os in
# Unix domain sockets are faster now.
DEFAULT_LOCAL_TRANS="UNIX_TRANS,LOCAL_TRANS,TCP_TRANS"
;;
+ linux*)
+ # LOCAL_TRANS is used for abstract sockets.
+ DEFAULT_LOCAL_TRANS="LOCAL_TRANS,UNIX_TRANS,TCP_TRANS"
+ ;;
*)
if test "$LOCALCONN" = "yes"; then
DEFAULT_LOCAL_TRANS="LOCAL_TRANS,UNIX_TRANS,TCP_TRANS"