summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn Tapsell <johnflux@gmail.com>2008-09-23 17:30:13 +0300
committerDaniel Stone <daniel@fooishbar.org>2008-09-23 17:30:13 +0300
commit58bf3aa746908f01c37be7045699e43a4e270944 (patch)
tree28968549a2b38e0098cf15a6a05ae94284fcf30d /configure.ac
parent340422a5c7a413faef18666cada27cee14615250 (diff)
Build: Use native compiler for makekeys
makekeys needs to be run during the build process, as opposed to on the target, so build it with either of gcc or cc to fix cross-compiling. This can be overridden by setting $CC_FOR_BUILD.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6be37b2f..97e3156e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,6 +22,12 @@ XORG_MACROS_VERSION(1.1)
AC_PROG_LIBTOOL
AC_PROG_CC
+if test x"$CC_FOR_BUILD" = x && test x"$cross_compiling" = xyes; then
+ AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc)
+else
+ CC_FOR_BUILD="$CC"
+fi
+
XORG_PROG_RAWCPP
# Build with XCB support?