summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-28 20:31:42 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-28 20:31:42 -0200
commit8ba0ca32a63c532f128bdca7f1bf982cab8e12be (patch)
tree70a043f6c9c64c0345b6b32db026b0e201d53890 /Makefile.am
parent091c1624fd2f9d933329d6152e4ecd865aa7903a (diff)
Janitor: ansification, make distcheck, compiler warnings.
Only convert to use "ansi prototypes" the functions warned from compilation with "./autogen.sh --prefix=/usr", on a Linux computer. Also, only address "trivial" compiler warning fixes in this commit. The new .gitignore is the output of a command like: % find . -name .gitignore -exec cat {} \; | sort | uniq and only the toplevel .gitignore file was kept.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5baa6c80..4fcad1c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,7 @@ if XCB
pkgconfig_DATA += x11-xcb.pc
endif
-EXTRA_DIST=x11.pc.in x11-xcb.pc.in ChangeLog autogen.sh
+EXTRA_DIST=x11.pc.in x11-xcb.pc.in ChangeLog
MAINTAINERCLEANFILES=ChangeLog
DISTCLEANFILES = doltcompile doltlibtool
@@ -19,7 +19,7 @@ DISTCLEANFILES = doltcompile doltlibtool
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog