summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4a72c19..db2f3b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,13 @@ AC_HEADER_STDC
# Needed to check for TCP & IPv6 support and set flags appropriately
XTRANS_CONNECTION_FLAGS
+AC_ARG_WITH(libuuid, AC_HELP_STRING([--with-libuuid], [Build with libuuid support for client IDs]))
+AM_CONDITIONAL(WITH_LIBUUID, test x"$with_libuuid" != xno)
+
+if test x"$with_uuid" != xno; then
+ PKG_CHECK_MODULES(LIBUUID, uuid)
+fi
+
if test "x$GCC" = "xyes"; then
GCC_WARNINGS="-Wall -Wpointer-arith -Wstrict-prototypes \
-Wmissing-prototypes -Wmissing-declarations \