summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndres Salomon <dilinger@debian.org>2008-10-25 20:50:21 +0200
committerJulien Cristau <jcristau@debian.org>2008-10-25 22:20:29 +0200
commitd9d49b57505bfffe99a5281423e7cf629f2dd2ab (patch)
tree8984db4135add3f6e142152be15b1690517982cd /configure.ac
parentdfd7a1b27d2da86843aeace1c4ff76d95c44eed2 (diff)
Bug#5176: cause configure to bail if mkfontscale or mkfontdir are not found
Signed-off-by: Julien Cristau <jcristau@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 465fc46..2425aaa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,13 @@ AC_PROG_INSTALL
AC_PATH_PROG(BDFTOPCF, bdftopcf)
AC_PATH_PROG(MKFONTSCALE, mkfontscale)
+if test x"$MKFONTSCALE" = x; then
+ AC_MSG_ERROR([mkfontscale is required to build sony-misc fonts.])
+fi
AC_PATH_PROG(MKFONTDIR, mkfontdir)
+if test x"$MKFONTDIR" = x; then
+ AC_MSG_ERROR([mkfontdir is required to build sony-misc fonts.])
+fi
m4_ifdef([AS_HELP_STRING], , [m4_define([AS_HELP_STRING], m4_defn([AC_HELP_STRING]))])