summaryrefslogtreecommitdiff
path: root/src/sna/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2011-09-21 19:06:07 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-07-30 12:57:13 +0100
commit8ebafa0493c0fa08ab9d80eeb1191b7560dc0863 (patch)
treeeb4bd0d22dcc1e3dac3c5d18dbfaeb616be90617 /src/sna/Makefile.am
parentca9d9c02a260bf7930e04bf64e93cc051893c04e (diff)
sna: Add the brw assembler
In order to construct programs on the fly to cater for the combinatorial number of possible shaders, we need an assembler, whilst also taking the opportunity to remove some of the inefficiencies and mistakes from the current shaders. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'src/sna/Makefile.am')
-rw-r--r--src/sna/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/sna/Makefile.am b/src/sna/Makefile.am
index 8463a80b..306996b5 100644
--- a/src/sna/Makefile.am
+++ b/src/sna/Makefile.am
@@ -18,7 +18,7 @@
# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-SUBDIRS = fb
+SUBDIRS = brw fb
AM_CFLAGS = \
@CWARNFLAGS@ \
@@ -34,7 +34,7 @@ AM_CFLAGS += @VALGRIND_CFLAGS@
endif
noinst_LTLIBRARIES = libsna.la
-libsna_la_LIBADD = @UDEV_LIBS@ -lm @DRM_LIBS@ fb/libfb.la
+libsna_la_LIBADD = @UDEV_LIBS@ -lm @DRM_LIBS@ brw/libbrw.la fb/libfb.la
libsna_la_SOURCES = \
blt.c \