summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bb381d6..5cfedb4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,6 +48,12 @@ x11perf_SOURCES = \
x11perf.h
bin_SCRIPTS = x11perfcomp
+CLEANFILES = $(bin_SCRIPTS)
+EXTRA_DIST = $(bin_SCRIPTS:=.in)
+DIR_SUBSTS = -e 's|@x11perfcompdir[@]|$(x11perfcompdir)|g'
+
+x11perfcomp: x11perfcomp.in
+ $(AM_V_GEN)$(SED) $(DIR_SUBSTS) < $(srcdir)/$@.in > $@
dist_x11perfcomp_SCRIPTS = \
fillblnk \