summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7e5e90..be90cf3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,11 @@ XORG_WITH_LINT
AC_CHECK_HEADERS([lastlog.h utmp.h utmpx.h sys/param.h])
# Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_MEMBERS([
+ struct utmp.ut_host,
+ struct utmp.ut_id,
+ struct utmp.ut_pid,
+ struct utmp.ut_type], [], [], [#include <utmp.h>])
AC_CHECK_MEMBERS([struct utmpx.ut_syslen], [], [], [#include <utmpx.h>])
# Checks for library functions.