summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-06 16:22:21 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-06 16:22:21 +0000
commitd487591b670d61283aa8482817af8dac6b82badb (patch)
tree7fcd5b98050bda8fec1420ca7d617cf6a955facb /Makefile.am
parentb17424c318b7b63dad281d43ac60944309b60d72 (diff)
Add buildsystem for fstobdf
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..0a29113
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,36 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = fstobdf
+
+fstobdf_CFLAGS = $(DEP_CFLAGS)
+fstobdf_LDADD = $(DEP_LIBS)
+
+fstobdf_SOURCES = \
+ chars.c \
+ fstobdf.c \
+ fstobdf.h \
+ header.c \
+ props.c
+
+dist_man_MANS = \
+ fstobdf.man
+