summaryrefslogtreecommitdiff
path: root/ewmh/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2014-02-06 16:55:53 -0500
committerArnaud Fontaine <arnau@debian.org>2014-02-13 18:52:49 +0900
commitdbc3e15004598dc94f26b7221ef5a61f4d3b2f61 (patch)
treed5d0b344938cd2ba47319a8869334637cc994c31 /ewmh/Makefile.am
parent18b823af6ab13aa0db0c814a07b43548aa953a68 (diff)
make: compile the library with standard xorg warning flags
The new BASE_CFLAGS variable contains only warning flags that do not alter the generated byte code, unlike the deprecated CWARNFLAGS which turns off the GNUCC strict aliasing optimization. Also, update m4 submodule as util-macros version 1.16 or later is required. Signed-off-by: Gaetan Nadon <memsize@videotron.ca> Signed-off-by: Arnaud Fontaine <arnau@debian.org>
Diffstat (limited to 'ewmh/Makefile.am')
-rw-r--r--ewmh/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/ewmh/Makefile.am b/ewmh/Makefile.am
index e2b428d..488d006 100644
--- a/ewmh/Makefile.am
+++ b/ewmh/Makefile.am
@@ -3,7 +3,7 @@ lib_LTLIBRARIES = libxcb-ewmh.la
nodist_xcbinclude_HEADERS = xcb_ewmh.h
-AM_CFLAGS = $(CWARNFLAGS)
+AM_CFLAGS = $(BASE_CFLAGS)
AM_CPPFLAGS = $(XCB_CFLAGS)
libxcb_ewmh_la_SOURCES = ewmh.c.m4 atomlist.m4 xcb_ewmh.h.m4