summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <hughsient@gmail.com>2013-05-09 20:31:09 +0100
committerKristian Høgsberg <krh@bitplanet.net>2013-05-10 12:51:08 -0400
commitb24e48e2ffbc499b940942bbc52b4fe636c14b58 (patch)
tree545ae2d9acdeab65a906e980e53d807e191f5fcd /src/Makefile.am
parent7b9195f9d6e84308a4a779f171fc7432e415ae10 (diff)
Add initial color management framework code
ICC profiles can now be specified in weston.ini for each output, or a CMS implementation can optionally loaded from a pluggable module.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ba08fe8e..0471294d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -96,6 +96,7 @@ moduledir = $(libdir)/weston
module_LTLIBRARIES = \
$(desktop_shell) \
$(tablet_shell) \
+ $(cms_static) \
$(x11_backend) \
$(drm_backend) \
$(wayland_backend) \
@@ -253,6 +254,17 @@ tablet_shell_la_SOURCES = \
tablet-shell-server-protocol.h
endif
+if HAVE_LCMS
+cms_static = cms-static.la
+cms_static_la_LDFLAGS = -module -avoid-version
+cms_static_la_LIBADD = $(COMPOSITOR_LIBS) $(LCMS_LIBS) ../shared/libshared.la
+cms_static_la_CFLAGS = $(GCC_CFLAGS) $(COMPOSITOR_CFLAGS) $(LCMS_CFLAGS)
+cms_static_la_SOURCES = \
+ cms-static.c \
+ cms-helper.c \
+ cms-helper.h
+endif
+
BUILT_SOURCES = \
screenshooter-server-protocol.h \
screenshooter-protocol.c \