summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2014-09-04 17:32:10 +1000
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2014-09-22 10:30:41 +0300
commitf3e7eedf1c0824639a816519ccfbdacb946cc63f (patch)
tree8fcb84ab539acaf00260f353f9ddcbc529dfc07e /configure.ac
parent472f0c48e667ff13794bc86750f6c74baabdc284 (diff)
doc: replace publican with xmlto
Publican isn't packaged for some distros, xmlto is a lot more common. Most of what publican provides for us is the stylesheet anyway, so we can just use xmlto and the publican stylesheet to get roughly the same look. PDF and XML generation has been dropped, this needs a bit more more effort than a mere switchover to xmlto. The top-level directory structure imposed by publican is kept for now (specifically the Wayland/en-US/html tree). This makes it easier to transition over for packagers. Note that the list of files inside has changed. CSS files are taken from publican to keep a uniform look compared to previous documentations. Stylesheets are licensed under CC0 1.0 Universal license, see publican/LICENSE: 1. Files in the datadir/Common_Content directory and its subdirectories are licensed under the CC0 1.0 Universal license. To the extent possible under law, the developers of Publican waive all copyright and related or neighboring rights to the files contained in the datadir/Common_Content directory and its subdirectories. Acked-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index df1f92d..6f8220b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,14 +109,10 @@ if test "x$enable_documentation" = "xyes"; then
AC_MSG_ERROR([Documentation build requested but doxygen not found. Install doxygen or disable the documentation using --disable-documentation])
fi
- AC_PATH_PROG(PUBLICAN, publican)
+ AC_PATH_PROG(XMLTO, xmlto)
- if test "x$PUBLICAN" != "x"; then
- PUBLICAN_VERSION=[`$PUBLICAN -v | sed -e 's/version=v\?\([0-9]*\.[0-9]*\).*/\1/'`]
-
- if test [ 1 -eq `echo "${PUBLICAN_VERSION} < 2.8" | bc` ]; then
- AC_MSG_ERROR([Publican version is not supported. Install publican >= 2.8 or disable the documentation using --disable-documentation])
- fi
+ if test "x$XMLTO" = "x"; then
+ AC_MSG_ERROR([Documentation build requested but xmlto not found. Install xmlto or disable the documentation using --disable-documentation])
fi
AC_CONFIG_FILES([
@@ -124,7 +120,7 @@ if test "x$enable_documentation" = "xyes"; then
])
fi
-AM_CONDITIONAL([HAVE_PUBLICAN], [test "x$PUBLICAN" != "x"])
+AM_CONDITIONAL([HAVE_XMLTO], [test "x$XMLTO" != "x"])
AC_CONFIG_FILES([Makefile
cursor/wayland-cursor.pc