summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTiago Vignatti <tiago.vignatti@intel.com>2012-10-11 17:42:09 +0300
committerKristian Høgsberg <krh@bitplanet.net>2012-10-15 13:02:04 -0400
commite2db4cf26f9004f4b473bc0d8c6f277828f80c8b (patch)
tree0930fec754dc42961e6a7a4cc942c04f959657eb /configure.ac
parent29c20e2eb6624f1c8dfd08a042a802b689b7a293 (diff)
doc: Add auto-generated Wayland Library chapter
For now only Wayland Client API is described on that chapter, which is extracted via doxygen on ./src/wayland-client.h. We apply a stylesheet (doxygen-to-publican) on doxygen output so it becomes docbook valid. Now all we need to do is populate that header while developing in order to grow a decent documentation. So please use it! Signed-off-by: Tiago Vignatti <tiago.vignatti@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4261ae6..860d715 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,6 +78,11 @@ AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"])
if test "x$enable_documentation" = "xyes"; then
AC_PATH_PROG(PUBLICAN, publican)
+
+ AC_CONFIG_FILES([
+ doc/doxygen/wayland.doxygen
+ ])
+
fi
AM_CONDITIONAL([HAVE_PUBLICAN], [test "x$PUBLICAN" != "x"])
@@ -88,6 +93,7 @@ AC_CONFIG_FILES([Makefile
cursor/wayland-cursor-uninstalled.pc
doc/Makefile
doc/Wayland/Makefile
+ doc/doxygen/Makefile
doc/man/Makefile
src/Makefile
src/wayland-server-uninstalled.pc