summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f2f3a39c..f82b8d46e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,14 +40,19 @@ homepage: all dist
ln -sf README.html $$HOME/homepage/private/projects/nss-myhostname/index.html
.PHONY: homepage
libnss_myhostname_la_SOURCES = \
nss-myhostname.c \
- netlink.c \
- netlink.h
+ ifconf.h
+
+if LEGACY
+libnss_myhostname_la_SOURCES += legacy.c
+else
+libnss_myhostname_la_SOURCES += netlink.c
+endif
libnss_myhostname_la_LDFLAGS = \
-avoid-version \
-module \
-export-dynamic \
-shrext .so.2