summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrediano Ziglio <fziglio@redhat.com>2017-08-31 23:09:09 +0100
committerFrediano Ziglio <fziglio@redhat.com>2017-09-01 22:04:44 +0100
commite6cf0dd0569f1f05257ae84d57c68239b6f68b70 (patch)
tree26d7c740ffdb87fa4854738936042d4aa753fcc6 /configure.ac
parent0660e92017b8f24a159af071f66908ca8957c5c1 (diff)
build-sys: Fix syntax-check
This error was reported configure.ac:119:if test "x$have_gstreamer_0_10" = "xyes" -o "x$have_gstreamer_1_0" = "xyes"; then maint.mk: use "test C1 && test C2", not "test C1 -a C2"; use "test C1 || test C2", not "test C1 -o C2" Signed-off-by: Frediano Ziglio <fziglio@redhat.com> Acked-by: Jonathon Jongsma <jjongsma@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f80193b3..7d8afd57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -116,7 +116,7 @@ AS_IF([test x"$missing_gstreamer_elements" = xyes],
[SPICE_WARNING([The GStreamer video encoder can be built but may not work.])
])
-if test "x$have_gstreamer_0_10" = "xyes" -o "x$have_gstreamer_1_0" = "xyes"; then
+if test "x$have_gstreamer_0_10" = "xyes" || test "x$have_gstreamer_1_0" = "xyes"; then
PKG_CHECK_MODULES(ORC, orc-0.4)
AC_SUBST(ORC_CFLAGS)
AC_SUBST(ORC_LIBS)