summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7438542..8b8cd554 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -377,9 +377,6 @@ if (_signing_backends_count GREATER 0)
# This means that the order we append them to the list is significant
list(GET SIGNATURE_BACKENDS 0 DEFAULT_SIGNATURE_BACKEND)
endif()
- if (NOT DEFAULT_SIGNATURE_BACKEND IN_LIST SIGNATURE_BACKENDS)
- message(FATAL_ERROR "default signature backend must be one of ${SIGNATURE_BACKENDS}, was ${DEFAULT_SIGNATURE_BACKEND}")
- endif()
set(ENABLE_SIGNATURES ON)
endif()
if (NOT DEFAULT_SIGNATURE_BACKEND)
@@ -559,6 +556,12 @@ if (ENABLE_NSS3)
)
set(poppler_LIBS ${poppler_LIBS} PkgConfig::NSS3)
endif()
+if (ENABLE_GPGME)
+ set(poppler_SRCS ${poppler_SRCS}
+ poppler/GPGMECryptoSignBackend.cc
+ )
+ set(poppler_LIBS ${poppler_LIBS} Gpgmepp)
+endif()
if (OpenJPEG_FOUND)
set(poppler_SRCS ${poppler_SRCS}
poppler/JPEG2000Stream.cc