summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPino Toscano <pino@kde.org>2009-12-30 23:24:23 +0100
committerPino Toscano <pino@kde.org>2009-12-30 23:24:23 +0100
commitb156b4031f5daf658f40db8efa2a3016d95b98b5 (patch)
tree8ba34b53ce2ad7ca4f170054a640c03cd3733437 /configure.ac
parenta0cffb8b69e0595a2afe15ecc4928e0df1eeb063 (diff)
[cpp] add the build system stuff for iconv, mandatory for cpp
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a51eedea..102a0b2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -453,6 +453,12 @@ AC_ARG_ENABLE(poppler-cpp,
[Don't compile poppler cpp wrapper.]),
enable_poppler_cpp=$enableval,
enable_poppler_cpp="yes")
+if test x$enable_poppler_cpp = xyes; then
+ AM_ICONV()
+ if test x$am_func_iconv != xyes; then
+ enable_poppler_cpp=no
+ fi
+fi
AM_CONDITIONAL(BUILD_POPPLER_CPP, test "x$enable_poppler_cpp" = "xyes")