summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPino Toscano <pino@kde.org>2010-02-21 19:56:38 +0100
committerPino Toscano <pino@kde.org>2010-02-21 19:56:38 +0100
commita18dab9e53a20a76eb46fa3a868fffdd3c754ce2 (patch)
treeeb468aa272122f67b6e49dba955f8dcef03d3bed /configure.ac
parentfa0989297e95b6adebed71336ea206d1b279ab24 (diff)
parentf3862f7d987aae52a1fd2bb0af27d1cd803a5b84 (diff)
Merge remote branch 'origin/cpp-frontend'
* origin/cpp-frontend: (34 commits) [cpp/tests] poppler-dump: show a string for the font type [cpp/tests] poppler-dump: show the orientation of the pages [cpp/tests] poppler-dump: a bit less output in permissions lines [cpp/tests] poppler-dump: add --show-all to show all the information [cpp] use iconv for the utf8 <-> utf16 conversions [cpp] add the build system stuff for iconv, mandatory for cpp [cpp] fixup unicode GooString <-> ustring conversions [cpp] fix installation of poppler-version.h with autotools and builddir != srcdir simplify [cpp/tests] add a simple poppler-dump test [cpp] use the correct index (instead of an uninitialized variable) [cpp] properly delete the children of a toc item [cpp] actually implement toc::root() [cpp] fix the reference to the vector data [cpp] fix the reference to the vector data [cpp] add destructor for 'rectangle' [cpp] add out stream operators for rect and rectf [cpp] add namespace to namespace functiond to link properly [cpp] add default empty parameters for the passwords of the document loading functions [cpp] add "human friendly" output representation for byte_array ... Conflicts: config.h.cmake
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 26 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b8fb411c..5d497c37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -520,6 +520,25 @@ fi
AM_CONDITIONAL(BUILD_POPPLER_QT4, test "x$enable_poppler_qt4" = "xyes")
+dnl
+dnl CPP frontend
+dnl
+
+AC_ARG_ENABLE(poppler-cpp,
+ AC_HELP_STRING([--disable-poppler-cpp],
+ [Don't compile poppler cpp wrapper.]),
+ enable_poppler_cpp=$enableval,
+ enable_poppler_cpp="yes")
+if test x$enable_poppler_cpp = xyes; then
+ AM_ICONV()
+ if test x$am_func_iconv != xyes; then
+ enable_poppler_cpp=no
+ fi
+fi
+
+AM_CONDITIONAL(BUILD_POPPLER_CPP, test "x$enable_poppler_cpp" = "xyes")
+
+
AC_ARG_ENABLE(gtk-test,
AC_HELP_STRING([--disable-gtk-test],
[Don't compile GTK+ test program.]),
@@ -610,6 +629,7 @@ AC_SUBST(PC_REQUIRES_PRIVATE)
AC_SUBST([POPPLER_MAJOR_VERSION],[poppler_version_major])
AC_SUBST([POPPLER_MINOR_VERSION],[poppler_version_minor])
AC_SUBST([POPPLER_MICRO_VERSION],[poppler_version_micro])
+AC_SUBST([POPPLER_VERSION],[poppler_version])
AC_OUTPUT([
Makefile
@@ -628,12 +648,16 @@ qt4/Makefile
qt4/src/Makefile
qt4/tests/Makefile
qt4/demos/Makefile
+cpp/Makefile
+cpp/poppler-version.h
+cpp/tests/Makefile
poppler.pc
poppler-cairo.pc
poppler-splash.pc
poppler-glib.pc
poppler-qt.pc
-poppler-qt4.pc])
+poppler-qt4.pc
+poppler-cpp.pc])
echo ""
@@ -646,6 +670,7 @@ echo " qt wrapper: $enable_poppler_qt"
echo " qt4 wrapper: $enable_poppler_qt4"
echo " glib wrapper: $enable_poppler_glib"
echo " use GDK: $enable_gdk"
+echo " cpp wrapper: $enable_poppler_cpp"
echo " use gtk-doc: $enable_gtk_doc"
echo " use libjpeg: $enable_libjpeg"
echo " use libpng: $enable_libpng"