summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHib Eris <hib@hiberis.nl>2012-02-12 23:16:41 +0100
committerAlbert Astals Cid <aacid@kde.org>2012-02-12 23:17:23 +0100
commit9250449aaa279840d789b3a7cef75d06a0fd88e7 (patch)
tree950f04b5b3ae504d432f70f9e0365ad726801b8a /configure.ac
parent66cf1fdb3ba6894f61d9078f5c30046b464347ae (diff)
Improve moc detection when cross compiling
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3ab66097..7f19f070 100644
--- a/configure.ac
+++ b/configure.ac
@@ -508,13 +508,15 @@ AC_SUBST(POPPLER_QT4_LIBS)
AC_SUBST(POPPLER_QT4_TEST_LIBS)
if test x$enable_poppler_qt4 = xyes; then
+ AC_CHECK_TOOL(MOCQT4, moc)
AC_MSG_CHECKING([for Qt4 moc])
- MOCQT4=`which moc`
mocversion=`$MOCQT4 -v 2>&1`
mocversiongrep=`echo $mocversion | grep "Qt 4"`
if test x"$mocversiongrep" != x"$mocversion"; then
+ AC_MSG_RESULT([no])
# moc was not the qt4 one, try with moc-qt4
- MOCQT4=`which moc-qt4`
+ AC_CHECK_TOOL(MOCQT4, moc-qt4)
+ AC_MSG_CHECKING([for Qt4 moc-qt4])
mocversion=`$MOCQT4 -v 2>&1`
mocversiongrep=`echo $mocversion | grep "Qt 4"`
if test x"$mocversiongrep" != x"$mocversion"; then