summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHib Eris <hib@hiberis.nl>2010-01-13 22:20:41 +0000
committerAlbert Astals Cid <aacid@kde.org>2010-01-13 22:20:41 +0000
commit350ff407e06a961f2a5b9d203cb8e78ce09313a0 (patch)
tree53ffe2c1e1647908bc194dda36cb2802bb69668d /configure.ac
parent36b67b002db802bfad553720e2114b76b07bb614 (diff)
Make poppler (optionally) relocatable on Windows
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b22f467e..dae0a1e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,32 @@ AC_ARG_ENABLE(fixedpoint,
[ --enable-fixedpoint use fixed point (instead of double precision) arithmetic in the Splash backend],
AC_DEFINE(USE_FIXEDPOINT, [1], [Use fixed point arithmetic]))
+dnl Relocation support
+AC_ARG_ENABLE(relocatable,
+ AC_HELP_STRING([--disable-relocatable],
+ [Hardcode the poppler library location (on Windows).]),
+ enable_relocatable=$enableval,
+ [if test x$os_win32 = xyes; then
+ # default to yes on native Windows.
+ enable_relocatable="yes"
+ else
+ # default to no everywhere else.
+ enable_relocatable="no"
+ fi
+ ]
+)
+
+if test x$enable_relocatable = xyes; then
+ if test x$os_win32 = xyes; then
+ AC_DEFINE([ENABLE_RELOCATABLE],
+ [1],[Do not hardcode the library location])
+ else
+ AC_MSG_ERROR(
+ [Invalid setting for relocatable, only supported on windows])
+
+ fi
+fi
+
AC_DEFINE_DIR(POPPLER_DATADIR, "{datarootdir}/poppler", [Poppler data dir])
dnl ##### Checks for header files.