summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2005-03-03 19:45:58 +0000
committerKristian Høgsberg <krh@redhat.com>2005-03-03 19:45:58 +0000
commitcb02d5d0e770e2a8cbe5a8ac810820a2ce5fec0c (patch)
tree89a707862fc867a1aaa879ad3f6fbfb5f16a0a30 /Makefile.am
Initial revision
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..2d57f6d1
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,29 @@
+if BUILD_SPLASH_OUTPUT
+splash_subdir = splash
+endif
+
+SUBDIRS = goo fofi $(splash_subdir) poppler test
+
+EXTRA_DIST = \
+ README-XPDF \
+ poppler.pc.in \
+ poppler-cairo.pc.in \
+ poppler-splash.pc.in
+
+if BUILD_SPLASH_OUTPUT
+
+splash_pc_file = poppler-splash.pc
+
+endif
+
+if BUILD_CAIRO_OUTPUT
+
+cairo_pc_file = poppler-cairo.pc
+
+endif
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = \
+ poppler.pc \
+ $(cairo_pc_file) \
+ $(splash_pc_file)