summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlbert Astals Cid <aacid@kde.org>2018-12-13 22:41:27 +0100
committerAlbert Astals Cid <aacid@kde.org>2018-12-15 17:39:09 +0100
commit641312cb67c9f31188367323ea186f40cbb103e5 (patch)
tree4bc0bc8a62d464440ed0548667230c312fccae51 /CMakeLists.txt
parent7565f2366080304bfe4ab5846c90cf4cbc89457b (diff)
Make it more obvious that XPDF headers have unstable API/ABI
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f8131eb6..b9d1dfb1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,7 +44,7 @@ set (CMAKE_CXX_STANDARD 14)
set (CMAKE_CXX_EXTENSIONS OFF)
# command line switches
-option(ENABLE_XPDF_HEADERS "Install unsupported xpdf headers." OFF)
+option(ENABLE_UNSTABLE_API_ABI_HEADERS "Install API/ABI unstable xpdf headers." OFF)
option(BUILD_GTK_TESTS "Whether compile the GTK+ test programs." ON)
option(BUILD_QT5_TESTS "Whether compile the Qt5 test programs." ON)
option(BUILD_CPP_TESTS "Whether compile the CPP test programs." ON)
@@ -495,7 +495,7 @@ if(CMAKE_USE_PTHREADS_INIT)
endif()
install(TARGETS poppler RUNTIME DESTINATION bin LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-if(ENABLE_XPDF_HEADERS)
+if(ENABLE_UNSTABLE_API_ABI_HEADERS)
install(FILES
poppler/Annot.h
poppler/Array.h