summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHannah von Reth <vonreth@kde.org>2018-08-16 15:39:28 +0200
committerAlbert Astals Cid <aacid@kde.org>2018-08-16 15:39:28 +0200
commit1b0b9e14e25494dfc08bbb9fe7232c7fca0d7f32 (patch)
tree05ba180489ae1377c3439fff9372161243930e09 /CMakeLists.txt
parent12bf632489587df9da416ed8303fb8aefc26bdac (diff)
Remove wchar_t- on MSVC
Qt is built with wchar_t so if you try to build poppler without it, there are conflicting types and everything fails
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da9d5364..4898274a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -485,7 +485,6 @@ endif()
if(MSVC)
add_definitions(-D_CRT_SECURE_NO_WARNINGS)
-set(CMAKE_CXX_FLAGS "/Zc:wchar_t- ${CMAKE_CXX_FLAGS}")
add_library(poppler STATIC ${poppler_SRCS})
else()
add_library(poppler ${poppler_SRCS})